Cipher.update_into can corrupt memory if passed an immutable python object as the outbuf
CVE-2023-23931GHSA-w7pp-m8wf-vj6r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 39.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cryptography
- Affected
- >= 1.8, < 39.0.1
- Fixed in
- 39.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w7pp-m8wf-vj6r lists affected ranges: PyPI cryptography >=1.8 <39.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w7pp-m8wf-vj6r lists affected ranges: PyPI cryptography >=1.8 <39.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-23931: 1.30% estimated exploitation activity in the next 30 days; percentile 70.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Previously, Cipher.updateinto would accept Python objects which implement the buffer protocol, but provide only immutable buffers: This would allow immutable objects (such as bytes) to be mutated, thus violating fundamental rules of Python. This is a soundness bug -- it allows programmers to misuse an API, it cannot be exploited by attacker controlled data alone. This now correctly raises an exception. This issue has been present since updateinto was originally introduced in cryptography 1.8.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w7pp-m8wf-vj6r
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w7pp-m8wf-vj6r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-23931 Advisory: Cipher.update_into can corrupt memory if passed an immutable python object as the outbuf IDs: CVE-2023-23931, GHSA-w7pp-m8wf-vj6r Record: https://patchnext.com/advisories/cve-2023-23931 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cryptography 39.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cryptography: affected >= 1.8, < 39.0.1; fixed in 39.0.1 ## Suggested inspection (read-only) - `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cryptography. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w7pp-m8wf-vj6r (OSV record GHSA-w7pp-m8wf-vj6r lists affected ranges: PyPI cryptography >=1.8 <39.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-w7pp-m8wf-vj6r (GitHub-reviewed advisory GHSA-w7pp-m8wf-vj6r lists affected ranges: PyPI cryptography >=1.8 <39.0.1) Commands are suggestions: review each one before running it.
Loading voting…