Skip to content

← Actionable
High, CVSS 8.6amended

Pickle serialization vulnerable to Deserialization of Untrusted Data

CVE-2023-23930GHSA-5m22-cfq9-86x6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6 4.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vantage6

    Affected
    < 4.0.2
    Fixed in
    4.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-23930: 1.11% estimated exploitation activity in the next 30 days; percentile 65.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

What We are using pickle as default serialization module but that has known security issues (see e.g. https://medium.com/ochrona/python-pickle-is-notoriously-insecure-d6651f1974c9). In summary, it is not advisable to open Pickles that you create yourself locally. In vantage6, algorithms use pickles to send aggregated data around and to pack algorithm input or output. All of the Python algorithms that use the wrappers with default serialization are therefore vulnerable to this issue. Solution: we should use JSON instead Impact All users of vantage6 that post tasks with algorithms that use the default serialization. The default serialization is used by default with all algorithm wrappers. Patches Not yet Workarounds Specify JSON serialization

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5m22-cfq9-86x6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5m22-cfq9-86x6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-23930

Advisory: Pickle serialization vulnerable to Deserialization of Untrusted Data
IDs: CVE-2023-23930, GHSA-5m22-cfq9-86x6
Record: https://patchnext.com/advisories/cve-2023-23930 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vantage6 4.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vantage6: affected < 4.0.2; fixed in 4.0.2

## Suggested inspection (read-only)
- `python -m pip show vantage6`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vantage6.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5m22-cfq9-86x6 (OSV record GHSA-5m22-cfq9-86x6 lists affected ranges: PyPI vantage6 >=0 <4.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5m22-cfq9-86x6 (GitHub-reviewed advisory GHSA-5m22-cfq9-86x6 lists affected ranges: PyPI vantage6 >=0 <4.0.2)

Commands are suggestions: review each one before running it.

Loading voting…