Skip to content

← Actionable
Medium, CVSS 6.1

Craft CMS Stored Cross-site Scripting Injection Vulnerability

CVE-2023-23927GHSA-qcrj-6ffc-v7hq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 4.3.7, 3.7.64), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 4.0.0-RC1, < 4.3.7>= 3.7.24, < 3.7.64
    Fixed in
    3.7.64, 4.3.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-23927: 0.80% estimated exploitation activity in the next 30 days; percentile 56.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When you insert a payload inside a label name or instruction of an entry type, an XSS happens in the quick post widget on the admin dashboard. PoC Complete instructions, including specific configuration details, to reproduce the vulnerability. Impact Tested with the free version of Craft CMS 4.3.6.1

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qcrj-6ffc-v7hq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-23927

Advisory: Craft CMS Stored Cross-site Scripting Injection Vulnerability
IDs: CVE-2023-23927, GHSA-qcrj-6ffc-v7hq
Record: https://patchnext.com/advisories/cve-2023-23927 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 4.3.7, 3.7.64. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 4.0.0-RC1, < 4.3.7; >= 3.7.24, < 3.7.64; fixed in 3.7.64, 4.3.7

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qcrj-6ffc-v7hq (GitHub-reviewed advisory GHSA-qcrj-6ffc-v7hq lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =3.7.24 <3.7.64)

Commands are suggestions: review each one before running it.

Loading voting…