Skip to content

← Actionable
Critical, CVSS 10.0

Dompdf vulnerable to URI validation failure on SVG parsing

CVE-2023-23924GHSA-3cw5-7cxw-v5qg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dompdf/dompdf 2.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:H
EPSS
  • CVE-2023-23924: 3.57% estimated exploitation activity in the next 30 days; percentile 89.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The URI validation on dompdf 2.0.1 can be bypassed on SVG parsing by passing <image tags with uppercase letters. This might leads to arbitrary object unserialize on PHP < 8, through the phar URL wrapper. Details The bug occurs during SVG parsing of <image tags, in src/Image/Cache.php : This part will try to detect <image tags in SVG, and will take the href to validate it against the protocolAllowed whitelist. However, the $name comparison with "image" is case sensitive, which means that such a tag in the SVG will pass : As the tag is named "Image" and not "image", it will not pass the condition to trigger the check. A correct solution would be to strtolower the $name before the check : PoC Parsing the following SVG file is sufficient to reproduce the vulnerability : Impact An attacker might be able to exploit the vulnerability to call arbitrary URL with arbitrary protocols, if they can provide a SVG file to dompdf. In PHP versions before 8.0.0, it leads to arbitrary…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3cw5-7cxw-v5qg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-23924

Advisory: Dompdf vulnerable to URI validation failure on SVG parsing
IDs: CVE-2023-23924, GHSA-3cw5-7cxw-v5qg
Record: https://patchnext.com/advisories/cve-2023-23924 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dompdf/dompdf 2.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist dompdf/dompdf: affected < 2.0.2; fixed in 2.0.2

## Suggested inspection (read-only)
- Packagist dompdf/dompdf: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dompdf/dompdf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3cw5-7cxw-v5qg (GitHub-reviewed advisory GHSA-3cw5-7cxw-v5qg lists affected ranges: Packagist dompdf/dompdf >=0 <2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…