rails-ujs vulnerable to DOM Based Cross-site Scripting contenteditable HTML Elements
CVE-2023-23913GHSA-xp5h-f8jf-rc8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionview 7.0.4.3, 6.1.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems actionview
- Affected
- >= 5.1.0, < 6.1.7.3>= 7.0.0, < 7.0.4.3
- Fixed in
- 6.1.7.3, 7.0.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xp5h-f8jf-rc8q lists affected ranges: RubyGems actionview >=5.1.0 =7.0.0 <7.0.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2023-23913: 0.64% estimated exploitation activity in the next 30 days; percentile 50.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NOTE: rails-ujs is part of Rails/actionview since 5.1.0. There is a potential DOM based cross-site scripting issue in rails-ujs which leverages the Clipboard API to target HTML elements that are assigned the contenteditable attribute. This has the potential to occur when pasting malicious HTML content from the clipboard that includes a data-method, data-remote or data-disable-with attribute. This vulnerability has been assigned the CVE identifier CVE-2023-23913. Not affected: < 5.1.0 Versions Affected: = 5.1.0 Fixed Versions: 6.1.7.3, 7.0.4.3 Impact If the specified malicious HTML clipboard content is provided to a contenteditable element, this could result in the arbitrary execution of javascript on the origin in question. Releases The FIXED releases are available at the normal locations. Workarounds We recommend that all users upgrade to one of the FIXED versions. In the meantime, users can attempt to mitigate this vulnerability by removing the contenteditable attribute from…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xp5h-f8jf-rc8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-23913 Advisory: rails-ujs vulnerable to DOM Based Cross-site Scripting contenteditable HTML Elements IDs: CVE-2023-23913, GHSA-xp5h-f8jf-rc8q Record: https://patchnext.com/advisories/cve-2023-23913 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: actionview 7.0.4.3, 6.1.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems actionview: affected >= 5.1.0, < 6.1.7.3; >= 7.0.0, < 7.0.4.3; fixed in 6.1.7.3, 7.0.4.3 ## Suggested inspection (read-only) - RubyGems actionview: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on actionview. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xp5h-f8jf-rc8q (GitHub-reviewed advisory GHSA-xp5h-f8jf-rc8q lists affected ranges: RubyGems actionview >=5.1.0 =7.0.0 <7.0.4.3) Commands are suggestions: review each one before running it.
Loading voting…