WPGraphQL Plugin vulnerable to Server Side Request Forgery (SSRF)
CVE-2023-23684GHSA-cfh4-7wq9-6pgg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wp-graphql/wp-graphql 1.14.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wp-graphql/wp-graphql
- Affected
- <= 1.14.5
- Fixed in
- 1.14.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cfh4-7wq9-6pgg lists affected ranges: Packagist wp-graphql/wp-graphql >=0 <=1.14.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-23684: 0.45% estimated exploitation activity in the next 30 days; percentile 39.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users with capabilities to upload media (editors and above) are succeptible to SSRF (Server-Side Request Forgery) when executing the createMediaItem Mutation. Authenticated users making GraphQL requests that execute the createMediaItem could pass executable paths in the mutations filePath argument that could give them unwarranted access to the server. It's recommended to update to WPGraphQL v1.14.6 or newer. If you're unable to do so, below is a snippet you can add to your functions.php (or similar) that filters the createMediaItem mutation's resolver. Patches - v1.14.6 - https://github.com/wp-graphql/wp-graphql/pull/2840 Workarounds If you're unable to upgrade to v1.14.6 or higher, you should be able to use the following snippet in your functions.php to override the vulnerable resolver. This snippet has been tested as far back as WPGraphQL v0.15 References -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cfh4-7wq9-6pgg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-23684 Advisory: WPGraphQL Plugin vulnerable to Server Side Request Forgery (SSRF) IDs: CVE-2023-23684, GHSA-cfh4-7wq9-6pgg Record: https://patchnext.com/advisories/cve-2023-23684 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wp-graphql/wp-graphql 1.14.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wp-graphql/wp-graphql: affected <= 1.14.5; fixed in 1.14.6 ## Suggested inspection (read-only) - Packagist wp-graphql/wp-graphql: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wp-graphql/wp-graphql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cfh4-7wq9-6pgg (GitHub-reviewed advisory GHSA-cfh4-7wq9-6pgg lists affected ranges: Packagist wp-graphql/wp-graphql >=0 <=1.14.5) Commands are suggestions: review each one before running it.
Loading voting…