Skip to content

← Actionable
Medium, CVSS 5.9

Denial of service via HAMT Decoding Panics

CVE-2023-23625GHSA-q264-w97q-q778

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ipfs/go-unixfs 0.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-23625: 0.68% estimated exploitation activity in the next 30 days; percentile 52.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Trying to read malformed HAMT sharded directories can cause panics and virtual memory leaks. If you are reading untrusted user input, an attacker can then trigger a panic. This is caused by bogus fanout parameter in the HAMT directory nodes. This include checks returned in ipfs/go-bitfield GHSA-2h6c-j3gf-xp9r, as well as limiting the fanout to <= 1024 (to avoid attempts of arbitrary sized allocations). Patches - https://github.com/ipfs/go-unixfs/commit/dbcc43ec3e2db0d01e8d80c55040bba3cf22cb4b Workarounds Do not feed untrusted user data to the decoding functions. References - https://github.com/ipfs/go-bitfield/security/advisories/GHSA-2h6c-j3gf-xp9r

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q264-w97q-q778

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-23625

Advisory: Denial of service via HAMT Decoding Panics
IDs: CVE-2023-23625, GHSA-q264-w97q-q778
Record: https://patchnext.com/advisories/cve-2023-23625 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ipfs/go-unixfs 0.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ipfs/go-unixfs: affected < 0.4.3; fixed in 0.4.3

## Suggested inspection (read-only)
- Go github.com/ipfs/go-unixfs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ipfs/go-unixfs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q264-w97q-q778 (GitHub-reviewed advisory GHSA-q264-w97q-q778 lists affected ranges: Go github.com/ipfs/go-unixfs >=0 <0.4.3)

Commands are suggestions: review each one before running it.

Loading voting…