Electron's Content-Secrity-Policy disabling eval not applied consistently in renderers with sandbox disabled
CVE-2023-23623GHSA-gxh7-wv9q-fwfr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 23.0.0-alpha.2, 22.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron
- Affected
- >= 22.0.0-beta.1, < 22.0.1>= 23.0.0-alpha.1, < 23.0.0-alpha.2
- Fixed in
- 22.0.1, 23.0.0-alpha.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gxh7-wv9q-fwfr lists affected ranges: npm electron >=22.0.0-beta.1 =23.0.0-alpha.1 <23.0.0-alpha.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gxh7-wv9q-fwfr lists affected ranges: npm electron >=22.0.0-beta.1 =23.0.0-alpha.1 <23.0.0-alpha.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-23623: 0.66% estimated exploitation activity in the next 30 days; percentile 51.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Content-Security-Policy that disables eval, specifically setting a script-src directive and not providing unsafe-eval in that directive, is not respected in renderers that have sandbox and contextIsolation disabled. i.e. sandbox: false and contextIsolation: false in the webPreferences object. This resulted in incorrectly allowing usage of methods like eval() and new Function, which can result in an expanded attack surface. Patches This issue only ever affected the 22 and 23 major versions of Electron and has been fixed in the latest versions of those release lines. Specifically, these versions contain the fixes: - 22.0.1 - 23.0.0-alpha.2 We recommend all apps upgrade to the latest stable version of Electron, especially if they use sandbox: false or contextIsolation: false. Workarounds If upgrading isn't possible, this issue can be addressed without upgrading by enabling at least one of sandbox: true or contextIsolation: true on all renderers. For more information If you have…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gxh7-wv9q-fwfr
- Revision 1 · created ·
Published from osv record GHSA-gxh7-wv9q-fwfr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-23623 Advisory: Electron's Content-Secrity-Policy disabling eval not applied consistently in renderers with sandbox disabled IDs: CVE-2023-23623, GHSA-gxh7-wv9q-fwfr Record: https://patchnext.com/advisories/cve-2023-23623 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron 23.0.0-alpha.2, 22.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron: affected >= 22.0.0-beta.1, < 22.0.1; >= 23.0.0-alpha.1, < 23.0.0-alpha.2; fixed in 22.0.1, 23.0.0-alpha.2 ## Suggested inspection (read-only) - `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gxh7-wv9q-fwfr (OSV record GHSA-gxh7-wv9q-fwfr lists affected ranges: npm electron >=22.0.0-beta.1 =23.0.0-alpha.1 <23.0.0-alpha.2 (fixed)) - Verified: https://github.com/advisories/GHSA-gxh7-wv9q-fwfr (GitHub-reviewed advisory GHSA-gxh7-wv9q-fwfr lists affected ranges: npm electron >=22.0.0-beta.1 =23.0.0-alpha.1 <23.0.0-alpha.2) Commands are suggestions: review each one before running it.
Loading voting…