Field-level security issue with .keyword fields in OpenSearch
CVE-2023-23613GHSA-v3cg-7r9h-r2g6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.plugin:opensearch-security 2.5.0, 1.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opensearch.plugin:opensearch-security
- Affected
- < 1.3.8>= 2.0.0, < 2.5.0
- Fixed in
- 2.5.0, 1.3.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v3cg-7r9h-r2g6 lists affected ranges: Maven org.opensearch.plugin:opensearch-security >=0 =2.0.0 <2.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-23613: 0.82% estimated exploitation activity in the next 30 days; percentile 57.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Advisory title: Field-level security issue with .keyword fields Affected versions: OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 Patched versions: OpenSearch 1.3.8 and 2.5.0 Impact: There is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. Workaround: FLS rules that use explicit exclusions can be written to grant explicit access instead. Policies authored in this way are not subject to this issue. Patches: OpenSearch versions 1.3.8 and 2.5.0 contain a fix for this issue. For more information: If you have any questions or comments about this advisory, please contact AWS/Amazon Security via our issue reporting page (https://aws.amazon.com/security/vulnerability-reporting/) or directly via email to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v3cg-7r9h-r2g6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-23613 Advisory: Field-level security issue with .keyword fields in OpenSearch IDs: CVE-2023-23613, GHSA-v3cg-7r9h-r2g6 Record: https://patchnext.com/advisories/cve-2023-23613 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opensearch.plugin:opensearch-security 2.5.0, 1.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opensearch.plugin:opensearch-security: affected < 1.3.8; >= 2.0.0, < 2.5.0; fixed in 2.5.0, 1.3.8 ## Suggested inspection (read-only) - Maven org.opensearch.plugin:opensearch-security: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opensearch.plugin:opensearch-security. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v3cg-7r9h-r2g6 (GitHub-reviewed advisory GHSA-v3cg-7r9h-r2g6 lists affected ranges: Maven org.opensearch.plugin:opensearch-security >=0 =2.0.0 <2.5.0) Commands are suggestions: review each one before running it.
Loading voting…