Skip to content

← Actionable
Medium, CVSS 5.4amended

Path traversal in spotipy

CVE-2023-23608GHSA-q764-g6fm-555v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (spotipy 2.22.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI spotipy

    Affected
    < 2.22.1
    Fixed in
    2.22.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
EPSS
  • CVE-2023-23608: 0.66% estimated exploitation activity in the next 30 days; percentile 51.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary If a malicious URI is passed to the library, the library can be tricked into performing an operation on a different API endpoint than intended. Details The code Spotipy uses to parse URIs and URLs accepts user data too liberally which allows a malicious user to insert arbitrary characters into the path that is used for API requests. Because it is possible to include .., an attacker can redirect for example a track lookup via spotifyApi.track() to an arbitrary API endpoint like playlists, but this is possible for other endpoints as well. Before the security advisory feature was enabled on GitHub, I was already in contact with Stéphane Bruckert via e-mail, and he asked me to look into a potential fix. My recommendation is to perform stricter parsing of URLs and URIs, which I implemented in the patch included at the end of the report. If you prefer, I can also invite you to a private fork of the repository. Impact The impact of this vulnerability depends heavily on what…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q764-g6fm-555v

  2. Revision 1 · created ·

    Published from osv record GHSA-q764-g6fm-555v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-23608

Advisory: Path traversal in spotipy
IDs: CVE-2023-23608, GHSA-q764-g6fm-555v
Record: https://patchnext.com/advisories/cve-2023-23608 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: spotipy 2.22.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI spotipy: affected < 2.22.1; fixed in 2.22.1

## Suggested inspection (read-only)
- `python -m pip show spotipy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on spotipy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q764-g6fm-555v (OSV record GHSA-q764-g6fm-555v lists affected ranges: PyPI spotipy >=0 <2.22.1 (fixed))
- Verified: https://github.com/advisories/GHSA-q764-g6fm-555v (GitHub-reviewed advisory GHSA-q764-g6fm-555v lists affected ranges: PyPI spotipy >=0 <2.22.1)

Commands are suggestions: review each one before running it.

Loading voting…