Skip to content

← Actionable
High, CVSS 8.8

SQL Injection in AssetController

CVE-2023-2338GHSA-4x35-vr82-xvj6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 10.5.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-2338: 0.91% estimated exploitation activity in the next 30 days; percentile 60.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact SQL injections in AssetController due to unsanitized concatenating strings in where clause. The attacker can dump database, alter data or perform dos on the backend database. Patches Update to version 10.5.21 or apply this patch manually https://github.com/pimcore/pimcore/commit/21e35af721c375ef4676ed50835e30d828e76520.patch Workarounds Apply patch https://github.com/pimcore/pimcore/commit/21e35af721c375ef4676ed50835e30d828e76520.patch manually. References https://huntr.dev/bounties/bbf59fa7-cf5b-4945-81b0-328adc710462/

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4x35-vr82-xvj6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-2338

Advisory: SQL Injection in AssetController
IDs: CVE-2023-2338, GHSA-4x35-vr82-xvj6
Record: https://patchnext.com/advisories/cve-2023-2338 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 10.5.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/pimcore: affected < 10.5.21; fixed in 10.5.21

## Suggested inspection (read-only)
- Packagist pimcore/pimcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/pimcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4x35-vr82-xvj6 (GitHub-reviewed advisory GHSA-4x35-vr82-xvj6 lists affected ranges: Packagist pimcore/pimcore >=0 <10.5.21)

Commands are suggestions: review each one before running it.

Loading voting…