Path Traversal in Asset "import from server" option
CVE-2023-2336GHSA-hg77-vx9v-f49x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 10.5.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/pimcore
- Affected
- < 10.5.21
- Fixed in
- 10.5.21
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hg77-vx9v-f49x lists affected ranges: Packagist pimcore/pimcore >=0 <10.5.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-2336: 0.67% estimated exploitation activity in the next 30 days; percentile 51.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated attacker can abuse import-server-files with a path traversal to download an arbitrary file from the server An arbitrary file read vulnerability allows an attacker to read files on the server that they should not have access to, potentially including sensitive files such as configuration files, user data, and credentials. This can result in the exposure of confidential information, which can be used to launch further attacks or compromise the system. Patches Update to version 10.5.21 or apply this patch manually https://github.com/pimcore/pimcore/commit/498cadec2292f7842fb10612068ac78496e884b4.patch Workarounds Apply patch https://github.com/pimcore/pimcore/commit/498cadec2292f7842fb10612068ac78496e884b4.patch manually. References https://huntr.dev/bounties/af764624-7746-4f53-8480-85348dbb4f14/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hg77-vx9v-f49x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-2336 Advisory: Path Traversal in Asset "import from server" option IDs: CVE-2023-2336, GHSA-hg77-vx9v-f49x Record: https://patchnext.com/advisories/cve-2023-2336 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 10.5.21. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/pimcore: affected < 10.5.21; fixed in 10.5.21 ## Suggested inspection (read-only) - Packagist pimcore/pimcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/pimcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hg77-vx9v-f49x (GitHub-reviewed advisory GHSA-hg77-vx9v-f49x lists affected ranges: Packagist pimcore/pimcore >=0 <10.5.21) Commands are suggestions: review each one before running it.
Loading voting…