Apache Spark vulnerable to Improper Privilege Management
CVE-2023-22946GHSA-329j-jfvr-rhr6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.spark:spark-core_2.12 3.3.3; org.apache.spark:spark-core_2.13 3.3.3; pyspark 3.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.spark:spark-core_2.12
- Affected
- <= 3.3.2
- Fixed in
- 3.3.3
Maven org.apache.spark:spark-core_2.13
- Affected
- <= 3.3.2
- Fixed in
- 3.3.3
PyPI pyspark
- Affected
- < 3.3.2
- Fixed in
- 3.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-329j-jfvr-rhr6 lists affected ranges: Maven org.apache.spark:spark-core_2.12 >=0 =0 =0 <3.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-329j-jfvr-rhr6 lists affected ranges: Maven org.apache.spark:spark-core_2.12 >=0 =0 =0 <3.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-22946: 1.11% estimated exploitation activity in the next 30 days; percentile 65.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Spark versions prior to versions 3.4.0 and 3.3.3, applications using spark-submit can specify a proxy-user to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0, 3.3.3, or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-329j-jfvr-rhr6
- Revision 1 · created ·
Published from osv record GHSA-329j-jfvr-rhr6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22946 Advisory: Apache Spark vulnerable to Improper Privilege Management IDs: CVE-2023-22946, GHSA-329j-jfvr-rhr6 Record: https://patchnext.com/advisories/cve-2023-22946 (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.spark:spark-core_2.12 3.3.3; org.apache.spark:spark-core_2.13 3.3.3; pyspark 3.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.spark:spark-core_2.12: affected <= 3.3.2; fixed in 3.3.3 - Maven org.apache.spark:spark-core_2.13: affected <= 3.3.2; fixed in 3.3.3 - PyPI pyspark: affected < 3.3.2; fixed in 3.3.2 ## Suggested inspection (read-only) - Maven org.apache.spark:spark-core_2.12: check the installed version with your package manager. - Maven org.apache.spark:spark-core_2.13: check the installed version with your package manager. - `python -m pip show pyspark`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.spark:spark-core_2.12, org.apache.spark:spark-core_2.13, pyspark. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-329j-jfvr-rhr6 (OSV record GHSA-329j-jfvr-rhr6 lists affected ranges: Maven org.apache.spark:spark-core_2.12 >=0 =0 =0 <3.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-329j-jfvr-rhr6 (GitHub-reviewed advisory GHSA-329j-jfvr-rhr6 lists affected ranges: Maven org.apache.spark:spark-core_2.12 >=0 =0 =0 <3.3.2) Commands are suggestions: review each one before running it.
Loading voting…