Strapi leaking sensitive user information by filtering on private fields
CVE-2023-22894GHSA-jjqf-j4w7-92w8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/strapi 4.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @strapi/strapi
- Affected
- >= 3.2.1, < 4.8.0
- Fixed in
- 4.8.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jjqf-j4w7-92w8 lists affected ranges: npm @strapi/strapi >=3.2.1 <4.8.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2023-22894 to the Known Exploited Vulnerabilities catalog on 2026-10-08.
VerifiedObserved Listed in the CISA KEV JSON feed; separate from customer applicability.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jjqf-j4w7-92w8 lists affected ranges: npm @strapi/strapi >=3.2.1 <4.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2023-22894 to the Known Exploited Vulnerabilities catalog on 2026-10-08.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2026-10-08).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-22894: 4.11% estimated exploitation activity in the next 30 days; percentile 90.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Strapi through 4.7.1 allows unauthenticated attackers to discover sensitive user details for Strapi administrators and API users. Details Strapi through 4.7.1 allows unauthenticated attackers to discover sensitive user details for Strapi administrators and API users. The unauthenticated attacker can filter users by columns that contain sensitive information and infer the values by the changes in the API responses. An unauthenticated attacker can exploit this vulnerability to hijack Strapi administrator accounts and gain unauthorized Strapi Super Administrator access by leaking the password reset token and changing the admin password. This can be exploited on all Strapi versions <=4.7.1. IoC The exploitation of CVE-2023-22894 is easily detectable, since the payload is within the GET parameters and are normally included in request logs. The following regex pattern will extract requests that are exploiting this vulnerability to leak user's email, password and password reset…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jjqf-j4w7-92w8
- Revision 2 · evidence added ·
CISA KEV confirmed exploitation for CVE-2023-22894 (date added 2026-10-08). Customer workflow unchanged.
- Revision 1 · created ·
Published from osv record GHSA-jjqf-j4w7-92w8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22894 Advisory: Strapi leaking sensitive user information by filtering on private fields IDs: CVE-2023-22894, GHSA-jjqf-j4w7-92w8 Record: https://patchnext.com/advisories/cve-2023-22894 (revision 3, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: @strapi/strapi 4.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @strapi/strapi: affected >= 3.2.1, < 4.8.0; fixed in 4.8.0 ## Suggested inspection (read-only) - `npm ls @strapi/strapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @strapi/strapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jjqf-j4w7-92w8 (OSV record GHSA-jjqf-j4w7-92w8 lists affected ranges: npm @strapi/strapi >=3.2.1 <4.8.0 (fixed)) - Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2023-22894 to the Known Exploited Vulnerabilities catalog on 2026-10-08.) - Verified: https://github.com/advisories/GHSA-jjqf-j4w7-92w8 (GitHub-reviewed advisory GHSA-jjqf-j4w7-92w8 lists affected ranges: npm @strapi/strapi >=3.2.1 <4.8.0) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2023-22894 to the Known Exploited Vulnerabilities catalog on 2026-10-08.) Commands are suggestions: review each one before running it.
Loading voting…