ReDoS based DoS vulnerability in Active Support's underscore
CVE-2023-22796GHSA-j6gc-792m-qgm2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (activesupport 7.0.4.1, 6.1.7.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems activesupport
- Affected
- >= 7.0.0, < 7.0.4.1< 6.1.7.1
- Fixed in
- 6.1.7.1, 7.0.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j6gc-792m-qgm2 lists affected ranges: RubyGems activesupport >=7.0.0 =0 <6.1.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2023-22796: 1.71% estimated exploitation activity in the next 30 days; percentile 77.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a possible regular expression based DoS vulnerability in Active Support. This vulnerability has been assigned the CVE identifier CVE-2023-22796. Versions Affected: All Not affected: None Fixed Versions: 5.2.8.15 (Rails LTS, which is a paid service and not part of the rubygem), 6.1.7.1, 7.0.4.1 Impact A specially crafted string passed to the underscore method can cause the regular expression engine to enter a state of catastrophic backtracking. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability. This affects String#underscore, ActiveSupport::Inflector.underscore, String#titleize, and any other methods using these. All users running an affected release should either upgrade or use one of the workarounds immediately. Releases The FIXED releases are available at the normal locations. Workarounds There are no feasible workarounds for this issue. Users on Ruby 3.2.0 or greater may be able to reduce the impact by configuring…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j6gc-792m-qgm2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22796 Advisory: ReDoS based DoS vulnerability in Active Support's underscore IDs: CVE-2023-22796, GHSA-j6gc-792m-qgm2 Record: https://patchnext.com/advisories/cve-2023-22796 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: activesupport 7.0.4.1, 6.1.7.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems activesupport: affected >= 7.0.0, < 7.0.4.1; < 6.1.7.1; fixed in 6.1.7.1, 7.0.4.1 ## Suggested inspection (read-only) - RubyGems activesupport: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on activesupport. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j6gc-792m-qgm2 (GitHub-reviewed advisory GHSA-j6gc-792m-qgm2 lists affected ranges: RubyGems activesupport >=7.0.0 =0 <6.1.7.1) Commands are suggestions: review each one before running it.
Loading voting…