SQL Injection Vulnerability via ActiveRecord comments
CVE-2023-22794GHSA-hq7p-j377-6v63
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (activerecord 7.0.4.1, 6.1.7.1, 6.0.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems activerecord
- Affected
- >= 6.0.0, < 6.0.6.1>= 6.1.0, < 6.1.7.1>= 7.0.0, < 7.0.4.1
- Fixed in
- 6.1.7.1, 6.0.6.1, 7.0.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hq7p-j377-6v63 lists affected ranges: RubyGems activerecord >=6.0.0 =6.1.0 =7.0.0 <7.0.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-22794: 2.15% estimated exploitation activity in the next 30 days; percentile 82.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a possible vulnerability in ActiveRecord related to the sanitization of comments. This vulnerability has been assigned the CVE identifier CVE-2023-22794. Versions Affected: = 6.0.0 Not affected: < 6.0.0 Fixed Versions: 6.0.6.1, 6.1.7.1, 7.0.4.1 Impact Previously the implementation of escaping for comments was insufficient for If malicious user input is passed to either the annotate query method, the optimizerhints query method, or through the QueryLogs interface which automatically adds annotations, it may be sent to the database with insufficient sanitization and be able to inject SQL outside of the comment. In most cases these interfaces won’t be used with user input and users should avoid doing so. Example vulnerable code: Example vulnerable QueryLogs configuration (the default configuration is not vulnerable): All users running an affected release should either upgrade or use one of the workarounds immediately. Releases The FIXED releases are available at the normal…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hq7p-j377-6v63
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22794 Advisory: SQL Injection Vulnerability via ActiveRecord comments IDs: CVE-2023-22794, GHSA-hq7p-j377-6v63 Record: https://patchnext.com/advisories/cve-2023-22794 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: activerecord 7.0.4.1, 6.1.7.1, 6.0.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems activerecord: affected >= 6.0.0, < 6.0.6.1; >= 6.1.0, < 6.1.7.1; >= 7.0.0, < 7.0.4.1; fixed in 6.1.7.1, 6.0.6.1, 7.0.4.1 ## Suggested inspection (read-only) - RubyGems activerecord: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on activerecord. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hq7p-j377-6v63 (GitHub-reviewed advisory GHSA-hq7p-j377-6v63 lists affected ranges: RubyGems activerecord >=6.0.0 =6.1.0 =7.0.0 <7.0.4.1) Commands are suggestions: review each one before running it.
Loading voting…