Shopware has Insufficient Session Expiration in Administration
CVE-2023-22732GHSA-59qg-93jg-236f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.4.18.1; shopware/platform 6.4.18.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- <= 6.4.18.0
- Fixed in
- 6.4.18.1
Packagist shopware/platform
- Affected
- <= 6.4.18.0
- Fixed in
- 6.4.18.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-59qg-93jg-236f lists affected ranges: Packagist shopware/platform >=0 =0 <=6.4.18.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-22732: 0.76% estimated exploitation activity in the next 30 days; percentile 55.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Administration session expiration was set to one week, when an attacker has stolen the session cookie they could use it for a long period of time. Patches We added an automatic logout into the Administration, so the user will be logged out when they are inactive. References https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-59qg-93jg-236f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22732 Advisory: Shopware has Insufficient Session Expiration in Administration IDs: CVE-2023-22732, GHSA-59qg-93jg-236f Record: https://patchnext.com/advisories/cve-2023-22732 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.4.18.1; shopware/platform 6.4.18.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected <= 6.4.18.0; fixed in 6.4.18.1 - Packagist shopware/platform: affected <= 6.4.18.0; fixed in 6.4.18.1 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-59qg-93jg-236f (GitHub-reviewed advisory GHSA-59qg-93jg-236f lists affected ranges: Packagist shopware/platform >=0 =0 <=6.4.18.0) Commands are suggestions: review each one before running it.
Loading voting…