PgHero Allows Information Disclosure Through EXPLAIN Feature
CVE-2023-22626GHSA-vf99-xw26-86g5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pghero 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems pghero
- Affected
- < 3.1.0
- Fixed in
- 3.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vf99-xw26-86g5 lists affected ranges: RubyGems pghero >=0 <3.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-22626: 0.84% estimated exploitation activity in the next 30 days; percentile 57.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PgHero before 3.1.0 allows Information Disclosure via EXPLAIN because query results may be present in an error message. (Depending on database user privileges, this may only be information from the database, or may be information from file contents on the database server.)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vf99-xw26-86g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22626 Advisory: PgHero Allows Information Disclosure Through EXPLAIN Feature IDs: CVE-2023-22626, GHSA-vf99-xw26-86g5 Record: https://patchnext.com/advisories/cve-2023-22626 (revision 1, source checked 26 Oct 2026, 15:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pghero 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems pghero: affected < 3.1.0; fixed in 3.1.0 ## Suggested inspection (read-only) - RubyGems pghero: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pghero. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vf99-xw26-86g5 (GitHub-reviewed advisory GHSA-vf99-xw26-86g5 lists affected ranges: RubyGems pghero >=0 <3.1.0) Commands are suggestions: review each one before running it.
Loading voting…