Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin
CVE-2023-22621GHSA-2h87-4q2w-v4hf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/plugin-users-permissions 4.5.6; @strapi/plugin-email 4.5.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @strapi/plugin-users-permissions
- Affected
- < 4.5.6
- Fixed in
- 4.5.6
- Affected
- < 4.5.6
- Fixed in
- 4.5.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2h87-4q2w-v4hf lists affected ranges: npm @strapi/plugin-users-permissions >=0 =0 <4.5.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2h87-4q2w-v4hf lists affected ranges: npm @strapi/plugin-users-permissions >=0 =0 <4.5.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-22621: 70.60% estimated exploitation activity in the next 30 days; percentile 99.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Strapi through 4.5.5 allows authenticated Server-Side Template Injection (SSTI) that can be exploited to execute arbitrary code on the server. Details Strapi through 4.5.5 allows authenticated Server-Side Template Injection (SSTI) that can be exploited to execute arbitrary code on the server. A remote attacker with access to the Strapi admin panel can inject a crafted payload that executes code on the server into an email template that bypasses the validation checks that should prevent code execution. IoC Using just the request log files, the only IoC to search for is a PUT request to URL path /users-permissions/email-templates. This IoC only indicates that a Strapi email template was modified on your server and by itself does not indicate if your Strapi server has been compromised. If this IoC is detected, you will need to manually review your email templates on your Strapi server and backups of your database to see if any of the templates contain a lodash template delimiter…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2h87-4q2w-v4hf
- Revision 1 · created ·
Published from osv record GHSA-2h87-4q2w-v4hf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22621 Advisory: Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin IDs: CVE-2023-22621, GHSA-2h87-4q2w-v4hf Record: https://patchnext.com/advisories/cve-2023-22621 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @strapi/plugin-users-permissions 4.5.6; @strapi/plugin-email 4.5.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @strapi/plugin-users-permissions: affected < 4.5.6; fixed in 4.5.6 - npm @strapi/plugin-email: affected < 4.5.6; fixed in 4.5.6 ## Suggested inspection (read-only) - `npm ls @strapi/plugin-users-permissions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @strapi/plugin-email --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @strapi/plugin-users-permissions, @strapi/plugin-email. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2h87-4q2w-v4hf (OSV record GHSA-2h87-4q2w-v4hf lists affected ranges: npm @strapi/plugin-users-permissions >=0 =0 <4.5.6 (fixed)) - Verified: https://github.com/advisories/GHSA-2h87-4q2w-v4hf (GitHub-reviewed advisory GHSA-2h87-4q2w-v4hf lists affected ranges: npm @strapi/plugin-users-permissions >=0 =0 <4.5.6) Commands are suggestions: review each one before running it.
Loading voting…