Unsafe fall-through in getWhereConditions
CVE-2023-22579GHSA-vqfx-gj96-3w95
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sequelize 6.28.1; @sequelize/core 7.0.0-alpha.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sequelize
- Affected
- < 6.28.1
- Fixed in
- 6.28.1
npm @sequelize/core
- Affected
- < 7.0.0-alpha.20
- Fixed in
- 7.0.0-alpha.20
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vqfx-gj96-3w95 lists affected ranges: npm sequelize >=0 =0 <7.0.0-alpha.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vqfx-gj96-3w95 lists affected ranges: npm sequelize >=0 =0 <7.0.0-alpha.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-22579: 0.81% estimated exploitation activity in the next 30 days; percentile 56.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Providing an invalid value to the where option of a query caused Sequelize to ignore that option instead of throwing an error. A finder call like the following did not throw an error: As this option is typically used with plain javascript objects, be aware that this only happens at the top level of this option. Patches This issue has been patched in sequelize@6.28.1 & @sequelize/core@7.0.0.alpha-20 References A discussion thread about this issue is open at https://github.com/sequelize/sequelize/discussions/15698 CVE: CVE-2023-22579 Snyk: https://security.snyk.io/vuln/SNYK-JS-SEQUELIZE-3324090
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vqfx-gj96-3w95
- Revision 1 · created ·
Published from osv record GHSA-vqfx-gj96-3w95
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22579 Advisory: Unsafe fall-through in getWhereConditions IDs: CVE-2023-22579, GHSA-vqfx-gj96-3w95 Record: https://patchnext.com/advisories/cve-2023-22579 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sequelize 6.28.1; @sequelize/core 7.0.0-alpha.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sequelize: affected < 6.28.1; fixed in 6.28.1 - npm @sequelize/core: affected < 7.0.0-alpha.20; fixed in 7.0.0-alpha.20 ## Suggested inspection (read-only) - `npm ls sequelize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @sequelize/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sequelize, @sequelize/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vqfx-gj96-3w95 (OSV record GHSA-vqfx-gj96-3w95 lists affected ranges: npm sequelize >=0 =0 <7.0.0-alpha.20 (fixed)) - Verified: https://github.com/advisories/GHSA-vqfx-gj96-3w95 (GitHub-reviewed advisory GHSA-vqfx-gj96-3w95 lists affected ranges: npm sequelize >=0 =0 <7.0.0-alpha.20) Commands are suggestions: review each one before running it.
Loading voting…