Sequelize - Default support for “raw attributes” when using parentheses
CVE-2023-22578GHSA-f598-mfpv-gmfx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sequelize 6.29.0; @sequelize/core 7.0.0-alpha.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sequelize
- Affected
- < 6.29.0
- Fixed in
- 6.29.0
npm @sequelize/core
- Affected
- < 7.0.0-alpha.20
- Fixed in
- 7.0.0-alpha.20
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f598-mfpv-gmfx lists affected ranges: npm @sequelize/core >=0 =0 <6.29.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f598-mfpv-gmfx lists affected ranges: npm @sequelize/core >=0 =0 <6.29.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-22578: 0.83% estimated exploitation activity in the next 30 days; percentile 57.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Sequelize 6.28.2 and prior has a dangerous feature where using parentheses in the attribute option would make Sequelize use the string as-is in the SQL Produced Patches This feature was deprecated in Sequelize 5, and using it prints a deprecation warning. This issue has been patched in @sequelize/core@7.0.0.alpha-20 and sequelize@6.29.0. In Sequelize 7, it now produces the following: In Sequelize 6, it throws an error explaining that we had to introduce a breaking change, and requires the user to explicitly opt-in to either the Sequelize 7 behavior (always escape) or the Sequelize 5 behavior (inline attributes that include () without escaping). See https://github.com/sequelize/sequelize/pull/15710 for more information. Mitigations Do not use user-provided content to build your list or attributes. If you do, make sure that attribute in question actually exists on your model by checking that it exists in the rawAttributes property of your model first. --- A discussion thread…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f598-mfpv-gmfx
- Revision 1 · created ·
Published from osv record GHSA-f598-mfpv-gmfx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22578 Advisory: Sequelize - Default support for “raw attributes” when using parentheses IDs: CVE-2023-22578, GHSA-f598-mfpv-gmfx Record: https://patchnext.com/advisories/cve-2023-22578 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sequelize 6.29.0; @sequelize/core 7.0.0-alpha.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sequelize: affected < 6.29.0; fixed in 6.29.0 - npm @sequelize/core: affected < 7.0.0-alpha.20; fixed in 7.0.0-alpha.20 ## Suggested inspection (read-only) - `npm ls sequelize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @sequelize/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sequelize, @sequelize/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f598-mfpv-gmfx (OSV record GHSA-f598-mfpv-gmfx lists affected ranges: npm @sequelize/core >=0 =0 <6.29.0 (fixed)) - Verified: https://github.com/advisories/GHSA-f598-mfpv-gmfx (GitHub-reviewed advisory GHSA-f598-mfpv-gmfx lists affected ranges: npm @sequelize/core >=0 =0 <6.29.0) Commands are suggestions: review each one before running it.
Loading voting…