Uncaught Exception in yaml
CVE-2023-2251GHSA-f9xv-q969-pqx4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yaml 2.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm yaml
- Affected
- >= 2.0.0-5, < 2.2.2
- Fixed in
- 2.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f9xv-q969-pqx4 lists affected ranges: npm yaml >=2.0.0-5 <2.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f9xv-q969-pqx4 lists affected ranges: npm yaml >=2.0.0-5 <2.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-2251: 1.09% estimated exploitation activity in the next 30 days; percentile 65.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Uncaught Exception in GitHub repository eemeli/yaml starting at version 2.0.0-5 and prior to 2.2.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f9xv-q969-pqx4
- Revision 1 · created ·
Published from osv record GHSA-f9xv-q969-pqx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-2251 Advisory: Uncaught Exception in yaml IDs: CVE-2023-2251, GHSA-f9xv-q969-pqx4 Record: https://patchnext.com/advisories/cve-2023-2251 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yaml 2.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm yaml: affected >= 2.0.0-5, < 2.2.2; fixed in 2.2.2 ## Suggested inspection (read-only) - `npm ls yaml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yaml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f9xv-q969-pqx4 (OSV record GHSA-f9xv-q969-pqx4 lists affected ranges: npm yaml >=2.0.0-5 <2.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-f9xv-q969-pqx4 (GitHub-reviewed advisory GHSA-f9xv-q969-pqx4 lists affected ranges: npm yaml >=2.0.0-5 <2.2.2) Commands are suggestions: review each one before running it.
Loading voting…