Deno is vulnerable to race condition via interactive permission prompt spoofing
CVE-2023-22499GHSA-mc52-jpm2-cqh6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (deno 1.29.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io deno
- Affected
- >= 1.9.0, < 1.29.3
- Fixed in
- 1.29.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mc52-jpm2-cqh6 lists affected ranges: crates.io deno >=1.9.0 <1.29.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-22499: 0.62% estimated exploitation activity in the next 30 days; percentile 49.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Multi-threaded programs were able to spoof interactive permission prompt by rewriting the prompt to suggest that program is waiting on user confirmation to unrelated action. A malicious program could clear the terminal screen after permission prompt was shown and write a generic message like so: This situation impacts users who use Web Worker API and relied on interactive permission prompt. The reproduction is very timing sensitive and can’t be reliably reproduced on every try. This problem can not be exploited on systems that do not attach an interactive prompt (for example headless servers). Patches The problem has been fixed in Deno v1.29.3; it is recommended all users update to this version. Workarounds Run with --no-prompt flag to disable interactive permission prompts.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mc52-jpm2-cqh6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22499 Advisory: Deno is vulnerable to race condition via interactive permission prompt spoofing IDs: CVE-2023-22499, GHSA-mc52-jpm2-cqh6 Record: https://patchnext.com/advisories/cve-2023-22499 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: deno 1.29.3. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io deno: affected >= 1.9.0, < 1.29.3; fixed in 1.29.3 ## Suggested inspection (read-only) - crates.io deno: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on deno. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mc52-jpm2-cqh6 (GitHub-reviewed advisory GHSA-mc52-jpm2-cqh6 lists affected ranges: crates.io deno >=1.9.0 <1.29.3) Commands are suggestions: review each one before running it.
Loading voting…