RSSHub SSRF vulnerability
CVE-2023-22493GHSA-64wp-jh9p-5cg2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rsshub 1.0.0-master.a66cbcf), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm rsshub
- Affected
- < 1.0.0-master.a66cbcf
- Fixed in
- 1.0.0-master.a66cbcf
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-64wp-jh9p-5cg2 lists affected ranges: npm rsshub >=0 <1.0.0-master.a66cbcf (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-64wp-jh9p-5cg2 lists affected ranges: npm rsshub >=0 <1.0.0-master.a66cbcf
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:L
- EPSS
- CVE-2023-22493: 0.81% estimated exploitation activity in the next 30 days; percentile 56.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary RSSHub is vulnerable to Server-Side Request Forgery (SSRF) attacks. This vulnerability allows an attacker to send arbitrary HTTP requests from the server to other servers or resources on the network. Description An attacker can exploit this vulnerability by sending a request to the affected routes with a malicious URL. For example, if an attacker controls the ATTACKER.HOST domain, they can send a request to affected routes with the value set to ATTACKER.HOST%2F%23. The %2F and %23 characters are URL-encoded versions of the forward-slash (/) and pound (#) characters, respectively. In this context, an attacker could use those characters to append the base URL (i.e. https://${input}.defined.host) to be modified to https://ATTACKER.HOST/#.defined.host. This will cause the server to send a request to the attacker-controlled domain, allowing the attacker to potentially gain access to sensitive information or perform further attacks on the server. Impact An attacker could use this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-64wp-jh9p-5cg2
- Revision 1 · created ·
Published from osv record GHSA-64wp-jh9p-5cg2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22493 Advisory: RSSHub SSRF vulnerability IDs: CVE-2023-22493, GHSA-64wp-jh9p-5cg2 Record: https://patchnext.com/advisories/cve-2023-22493 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rsshub 1.0.0-master.a66cbcf. A vendor fix does not mean a deployment is fixed. ## Affected components - npm rsshub: affected < 1.0.0-master.a66cbcf; fixed in 1.0.0-master.a66cbcf ## Suggested inspection (read-only) - `npm ls rsshub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rsshub. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-64wp-jh9p-5cg2 (OSV record GHSA-64wp-jh9p-5cg2 lists affected ranges: npm rsshub >=0 <1.0.0-master.a66cbcf (fixed)) - Verified: https://github.com/advisories/GHSA-64wp-jh9p-5cg2 (GitHub-reviewed advisory GHSA-64wp-jh9p-5cg2 lists affected ranges: npm rsshub >=0 <1.0.0-master.a66cbcf) Commands are suggestions: review each one before running it.
Loading voting…