Skip to content

← Actionable
High, CVSS 8.1amended

gatsby-transformer-remark has possible unsanitized JavaScript code injection

CVE-2023-22491GHSA-7ch4-rr99-cqcw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gatsby-transformer-remark 6.3.2, 5.25.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-22491: 0.58% estimated exploitation activity in the next 30 days; percentile 47.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The gatsby-transformer-remark plugin prior to versions 5.25.1 and 6.3.2 passes input through to the gray-matter npm package, which is vulnerable to JavaScript injection in its default configuration, unless input is sanitized. The vulnerability is present in gatsby-transformer-remark when passing input in data mode (querying MarkdownRemark nodes via GraphQL). Injected JavaScript executes in the context of the build server. To exploit this vulnerability untrusted/unsanitized input would need to be sourced by or added into a file processed by gatsby-transformer-remark. The following payload demonstrates a vulnerable configuration: Patches A patch has been introduced in gatsby-transformer-remark@5.25.1 and gatsby-transformer-remark@6.3.2 which mitigates the issue by disabling the gray-matter JavaScript Frontmatter engine. The patch introduces a new option, JSFrontmatterEngine which is set to false by default. When setting JSFrontmatterEngine to true, input passed to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7ch4-rr99-cqcw

  2. Revision 1 · created ·

    Published from osv record GHSA-7ch4-rr99-cqcw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22491

Advisory: gatsby-transformer-remark has possible unsanitized JavaScript code injection
IDs: CVE-2023-22491, GHSA-7ch4-rr99-cqcw
Record: https://patchnext.com/advisories/cve-2023-22491 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gatsby-transformer-remark 6.3.2, 5.25.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm gatsby-transformer-remark: affected >= 6.0.0, < 6.3.2; < 5.25.1; fixed in 5.25.1, 6.3.2

## Suggested inspection (read-only)
- `npm ls gatsby-transformer-remark --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gatsby-transformer-remark.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7ch4-rr99-cqcw (OSV record GHSA-7ch4-rr99-cqcw lists affected ranges: npm gatsby-transformer-remark >=6.0.0 =0 <5.25.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7ch4-rr99-cqcw (GitHub-reviewed advisory GHSA-7ch4-rr99-cqcw lists affected ranges: npm gatsby-transformer-remark >=6.0.0 =0 <5.25.1)

Commands are suggestions: review each one before running it.

Loading voting…