Flarum post mentions can be used to read any post on the forum without access control
CVE-2023-22487GHSA-22m9-m3ww-53h3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/mentions 1.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist flarum/mentions
- Affected
- < 1.6.3
- Fixed in
- 1.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-22m9-m3ww-53h3 lists affected ranges: Packagist flarum/mentions >=0 <1.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2023-22487: 0.69% estimated exploitation activity in the next 30 days; percentile 52.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Using the mentions feature provided by the flarum/mentions extension, users can mention any post ID on the forum with the special @"<username"#p<id syntax. The following behavior never changes no matter if the actor should be able to read the mentioned post or not: A URL to the mentioned post is inserted into the actor post HTML, leaking its discussion ID and post number. The mentionsPosts relationship included in the POST /api/posts and PATCH /api/posts/<id JSON responses leaks the full JSON:API payload of all mentioned posts without any access control. This includes the content, date, number and attributes added by other extensions. An attacker only needs the ability to create new posts on the forum to exploit the vulnerability. This works even if new posts require approval. If they have the ability to edit posts, the attack can be performed even more discreetly by using a single post to scan any size of database and hiding the attack post content afterward. Impact The attack…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-22m9-m3ww-53h3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22487 Advisory: Flarum post mentions can be used to read any post on the forum without access control IDs: CVE-2023-22487, GHSA-22m9-m3ww-53h3 Record: https://patchnext.com/advisories/cve-2023-22487 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flarum/mentions 1.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist flarum/mentions: affected < 1.6.3; fixed in 1.6.3 ## Suggested inspection (read-only) - Packagist flarum/mentions: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flarum/mentions. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-22m9-m3ww-53h3 (GitHub-reviewed advisory GHSA-22m9-m3ww-53h3 lists affected ranges: Packagist flarum/mentions >=0 <1.6.3) Commands are suggestions: review each one before running it.
Loading voting…