Skip to content

← Actionable
High, CVSS 7.3

KubeOperator allows unauthorized access to system API

CVE-2023-22480GHSA-jxgp-jgh3-8jc8

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/KubeOperator/KubeOperator

    Affected
    <= 3.16.3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2023-22480: 66.77% estimated exploitation activity in the next 30 days; percentile 99.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Unauthorized access refers to the ability to bypass the system's preset permission settings to access some API interfaces. The attack exploits a flaw in how online applications handle routing permissions. Affected Version <= v3.16.3 Patches The vulnerability has been fixed in v3.16.3. https://github.com/KubeOperator/KubeOperator/commit/7ef42bf1c16900d13e6376f8be5ecdbfdfb44aaf Workarounds It is recommended to upgrade the version to v3.16.4. For more information If you have any questions or comments about this advisory, please open an issue. References https://github.com/KubeOperator/KubeOperator/releases/tag/v3.16.4

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jxgp-jgh3-8jc8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22480

Advisory: KubeOperator allows unauthorized access to system API
IDs: CVE-2023-22480, GHSA-jxgp-jgh3-8jc8
Record: https://patchnext.com/advisories/cve-2023-22480 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/KubeOperator/KubeOperator: affected <= 3.16.3

## Suggested inspection (read-only)
- Go github.com/KubeOperator/KubeOperator: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/KubeOperator/KubeOperator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jxgp-jgh3-8jc8 (GitHub-reviewed advisory GHSA-jxgp-jgh3-8jc8 lists affected ranges: Go github.com/KubeOperator/KubeOperator >=0 <=3.16.3)

Commands are suggestions: review each one before running it.

Loading voting…