Skip to content

← Actionable
High, CVSS 7.5

KubePi may allow unauthorized access to system API

CVE-2023-22478GHSA-gqx8-hxmv-c4v4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/KubeOperator/kubepi 1.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-22478: 3.74% estimated exploitation activity in the next 30 days; percentile 89.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Unauthorized access refers to the ability to bypass the system's preset permission settings to access some API interfaces. The attack exploits a flaw in how online applications handle routing permissions. Affected Version <= v1.6.3 Patches The vulnerability has been fixed in v1.6.4. https://github.com/KubeOperator/KubePi/commit/0c6774bf5d9003ae4d60257a3f207c131ff4a6d6 Workarounds It is recommended to upgrade the version to v1.6.4. For more information If you have any questions or comments about this advisory, please open an issue. References https://github.com/KubeOperator/KubePi/releases/tag/v1.6.4

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gqx8-hxmv-c4v4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22478

Advisory: KubePi may allow unauthorized access to system API
IDs: CVE-2023-22478, GHSA-gqx8-hxmv-c4v4
Record: https://patchnext.com/advisories/cve-2023-22478 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/KubeOperator/kubepi 1.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/KubeOperator/kubepi: affected <= 1.6.3; fixed in 1.6.4

## Suggested inspection (read-only)
- Go github.com/KubeOperator/kubepi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/KubeOperator/kubepi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gqx8-hxmv-c4v4 (GitHub-reviewed advisory GHSA-gqx8-hxmv-c4v4 lists affected ranges: Go github.com/KubeOperator/kubepi >=0 <=1.6.3)

Commands are suggestions: review each one before running it.

Loading voting…