Skip to content

← Actionable
High, CVSS 8.7amended

Parse Server option masterKeyIps vulnerability to IP spoofing

CVE-2023-22474GHSA-vm5r-c87r-pf6x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 5.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2023-22474: 0.66% estimated exploitation activity in the next 30 days; percentile 51.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Parse Server uses the request header x-forwarded-for to determine the client IP address. If Parse Server doesn't run behind a proxy server, then a client can set this header and Parse Server will trust the value of the header. The incorrect client IP address will be used by various features in Parse Server. This allows to circumvent the security mechanism of the Parse Server option masterKeyIps by setting an allowed IP address as the x-forwarded-for header value. Patches The mechanism to determine the client IP address has been rewritten. The correct IP address determination now requires to set the Parse Server option trustProxy accordingly, see the express framework's trust proxy setting. References - https://github.com/parse-community/parse-server/security/advisories/GHSA-vm5r-c87r-pf6x - https://expressjs.com/en/guide/behind-proxies.html

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vm5r-c87r-pf6x

  2. Revision 1 · created ·

    Published from osv record GHSA-vm5r-c87r-pf6x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22474

Advisory: Parse Server option `masterKeyIps` vulnerability to IP spoofing
IDs: CVE-2023-22474, GHSA-vm5r-c87r-pf6x
Record: https://patchnext.com/advisories/cve-2023-22474 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 5.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 5.4.1; fixed in 5.4.1

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vm5r-c87r-pf6x (OSV record GHSA-vm5r-c87r-pf6x lists affected ranges: npm parse-server >=0 <5.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vm5r-c87r-pf6x (GitHub-reviewed advisory GHSA-vm5r-c87r-pf6x lists affected ranges: npm parse-server >=0 <5.4.1)

Commands are suggestions: review each one before running it.

Loading voting…