Skip to content

← Actionable
High, CVSS 7.5amended

Luxon Inefficient Regular Expression Complexity vulnerability

CVE-2023-22467GHSA-3xq5-wjfh-ppjc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (luxon 3.2.1, 2.5.2, 1.28.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm luxon

    Affected
    >= 2.0.0, < 2.5.2>= 3.0.0, < 3.2.1>= 1.0.0, < 1.28.1
    Fixed in
    3.2.1, 2.5.2, 1.28.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-22467: 1.79% estimated exploitation activity in the next 30 days; percentile 78.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Luxon's DateTime.fromRFC2822() has quadratic (N^2) complexity on some specific inputs. This causes a noticeable slowdown for inputs with lengths above 10k characters. Users providing untrusted data to this method are therefore vulnerable to (Re)DoS attacks. This is the same bug as Moment's https://github.com/moment/moment/security/advisories/GHSA-wc69-rhjr-hc9g Workarounds Limit the length of the input. References There is an excellent writeup of the same issue in Moment: https://github.com/moment/moment/pull/6015#issuecomment-1152961973 Details DateTime.fromRFC2822("(".repeat(500000)) takes a couple minutes to complete.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3xq5-wjfh-ppjc

  2. Revision 1 · created ·

    Published from osv record GHSA-3xq5-wjfh-ppjc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22467

Advisory: Luxon Inefficient Regular Expression Complexity vulnerability
IDs: CVE-2023-22467, GHSA-3xq5-wjfh-ppjc
Record: https://patchnext.com/advisories/cve-2023-22467 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: luxon 3.2.1, 2.5.2, 1.28.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm luxon: affected >= 2.0.0, < 2.5.2; >= 3.0.0, < 3.2.1; >= 1.0.0, < 1.28.1; fixed in 3.2.1, 2.5.2, 1.28.1

## Suggested inspection (read-only)
- `npm ls luxon --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on luxon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3xq5-wjfh-ppjc (OSV record GHSA-3xq5-wjfh-ppjc lists affected ranges: npm luxon >=1.0.0 =2.0.0 =3.0.0 <3.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-3xq5-wjfh-ppjc (GitHub-reviewed advisory GHSA-3xq5-wjfh-ppjc lists affected ranges: npm luxon >=2.0.0 =3.0.0 =1.0.0 <1.28.1)

Commands are suggestions: review each one before running it.

Loading voting…