Skip to content

← Actionable
Critical, CVSS 9.8

KubePi allows malicious actor to login with a forged JWT token via Hardcoded Jwtsigkeys

CVE-2023-22463GHSA-vjhf-8vqx-vqpq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/KubeOperator/kubepi 1.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-22463: 69.67% estimated exploitation activity in the next 30 days; percentile 99.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The jwt authentication function of kubepi <= v1.6.2 uses hard-coded Jwtsigkeys, resulting in the same Jwtsigkeys for all online projects. This means that an attacker can forge any jwt token to take over the administrator account of any online project. Details session.go, the use of hard-coded JwtSigKey allows an attacker to use this value to forge jwt tokens arbitrarily. The JwtSigKey is confidential and should not be hard-coded in the code. Affected Version <= v1.6.2 Patches The vulnerability has been fixed in v1.6.3. https://github.com/KubeOperator/KubePi/commit/3be58b8df5bc05d2343c30371dd5fcf6a9fbbf8b : JWT key can be specified in app.yml, if leave it blank a random key will be used. Workarounds It is recommended to upgrade the version to v1.6.3. For more information If you have any questions or comments about this advisory, please open an issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vjhf-8vqx-vqpq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22463

Advisory: KubePi allows malicious actor to login with a forged JWT token via Hardcoded Jwtsigkeys
IDs: CVE-2023-22463, GHSA-vjhf-8vqx-vqpq
Record: https://patchnext.com/advisories/cve-2023-22463 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/KubeOperator/kubepi 1.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/KubeOperator/kubepi: affected <= 1.6.2; fixed in 1.6.3

## Suggested inspection (read-only)
- Go github.com/KubeOperator/kubepi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/KubeOperator/kubepi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vjhf-8vqx-vqpq (GitHub-reviewed advisory GHSA-vjhf-8vqx-vqpq lists affected ranges: Go github.com/KubeOperator/kubepi >=0 <=1.6.2)

Commands are suggestions: review each one before running it.

Loading voting…