Grafana vulnerable to Stored Cross-site Scripting in Text plugin
CVE-2023-22462GHSA-7rqg-hjwc-6mjf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/grafana/grafana 9.3.4, 9.2.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 9.2.0, < 9.2.10>= 9.3.0, < 9.3.4
- Fixed in
- 9.2.10, 9.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7rqg-hjwc-6mjf lists affected ranges: Go github.com/grafana/grafana >=9.2.0 =9.3.0 <9.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-22462: 1.56% estimated exploitation activity in the next 30 days; percentile 75.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description On 2023-01-01 during an internal audit of Grafana, a member of the security team found a stored XSS vulnerability affecting the core plugin "Text". The stored XSS vulnerability requires several user interactions in order to be fully exploited. The vulnerability was possible due to React's render cycle that will pass though the unsanitized HTML code, but in the next cycle the HTML is cleaned up and saved in Grafana's database. Impact An attacker needs to have the Editor role in order to change a Text panel to include JavaScript. later, an another user needs to edit the same Text panel, and click on "Markdown" or "HTML" for the code to be executed. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Impacted versions Grafana versions between 9.2.0 and 9.2.10. and between 9.3.0 and 9.3.4 Solutions and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7rqg-hjwc-6mjf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22462 Advisory: Grafana vulnerable to Stored Cross-site Scripting in Text plugin IDs: CVE-2023-22462, GHSA-7rqg-hjwc-6mjf Record: https://patchnext.com/advisories/cve-2023-22462 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/grafana/grafana 9.3.4, 9.2.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/grafana/grafana: affected >= 9.2.0, < 9.2.10; >= 9.3.0, < 9.3.4; fixed in 9.2.10, 9.3.4 ## Suggested inspection (read-only) - Go github.com/grafana/grafana: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/grafana/grafana. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7rqg-hjwc-6mjf (GitHub-reviewed advisory GHSA-7rqg-hjwc-6mjf lists affected ranges: Go github.com/grafana/grafana >=9.2.0 =9.3.0 <9.3.4) Commands are suggestions: review each one before running it.
Loading voting…