XWiki CKEditor.HTMLConverter vulnerable to Remote Code Execution via Cross-Site Request Forgery
CVE-2023-22457GHSA-6mjp-2rm6-9g85
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.contrib:application-ckeditor-ui 1.64.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.contrib:application-ckeditor-ui
- Affected
- < 1.64.3
- Fixed in
- 1.64.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6mjp-2rm6-9g85 lists affected ranges: Maven org.xwiki.contrib:application-ckeditor-ui >=0 <1.64.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-22457: 19.28% estimated exploitation activity in the next 30 days; percentile 97.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The CKEditor.HTMLConverter document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The attack can be demonstrated by accessing the URL <server/xwiki/bin/view/Main?sheet=CKEditor.HTMLConverter&language=en&sourceSyntax=xwiki%2F2.1&stripHTMLEnvelope=true&fromHTML=false&toHTML=true&text=%7B%7Bgroovy%7D%7Dprintln%28%22Hello+from+Groovy%21%22%29%7B%7B%2Fgroovy%7D%7D where <server is the URL of the XWiki installation as a user with programming rights. If this displays the text "Hello from Groovy!", the installation is vulnerable. Patches The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6mjp-2rm6-9g85
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22457 Advisory: XWiki CKEditor.HTMLConverter vulnerable to Remote Code Execution via Cross-Site Request Forgery IDs: CVE-2023-22457, GHSA-6mjp-2rm6-9g85 Record: https://patchnext.com/advisories/cve-2023-22457 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.contrib:application-ckeditor-ui 1.64.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.contrib:application-ckeditor-ui: affected < 1.64.3; fixed in 1.64.3 ## Suggested inspection (read-only) - Maven org.xwiki.contrib:application-ckeditor-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.contrib:application-ckeditor-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6mjp-2rm6-9g85 (GitHub-reviewed advisory GHSA-6mjp-2rm6-9g85 lists affected ranges: Maven org.xwiki.contrib:application-ckeditor-ui >=0 <1.64.3) Commands are suggestions: review each one before running it.
Loading voting…