MySQL Connectors takeover vulnerability
CVE-2023-22102GHSA-m6vm-37g8-gqvh
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.mysql:mysql-connector-j
- Affected
- < 8.2.0
- Fixed in
- 8.2.0
Maven mysql:mysql-connector-java
- Affected
- <= 8.0.33
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m6vm-37g8-gqvh lists affected ranges: Maven com.mysql:mysql-connector-j >=0 =0 <=8.0.33
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2023-22102: 0.99% estimated exploitation activity in the next 30 days; percentile 62.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J). Supported versions that are affected are 8.1.0 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in MySQL Connectors, attacks may significantly impact additional products (scope change). Successful attacks of this vulnerability can result in takeover of MySQL Connectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m6vm-37g8-gqvh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22102 Advisory: MySQL Connectors takeover vulnerability IDs: CVE-2023-22102, GHSA-m6vm-37g8-gqvh Record: https://patchnext.com/advisories/cve-2023-22102 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: com.mysql:mysql-connector-j 8.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.mysql:mysql-connector-j: affected < 8.2.0; fixed in 8.2.0 - Maven mysql:mysql-connector-java: affected <= 8.0.33 ## Suggested inspection (read-only) - Maven com.mysql:mysql-connector-j: check the installed version with your package manager. - Maven mysql:mysql-connector-java: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.mysql:mysql-connector-j, mysql:mysql-connector-java. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m6vm-37g8-gqvh (GitHub-reviewed advisory GHSA-m6vm-37g8-gqvh lists affected ranges: Maven com.mysql:mysql-connector-j >=0 =0 <=8.0.33) Commands are suggestions: review each one before running it.
Loading voting…