Skip to content

← Actionable
Medium, CVSS 5.9

Harbor timing attack risk

CVE-2023-20902GHSA-mq6f-5xh5-hgcf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/goharbor/harbor 2.8.3, 2.7.3, 1.10.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-20902: 0.45% estimated exploitation activity in the next 30 days; percentile 39.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In the Harbor jobservice container, the comparison of secrets in the authenticator type is prone to timing attacks. The vulnerability occurs due to the following code: https://github.com/goharbor/harbor/blob/aaea068cceb4063ab89313d9785f2b40f35b0d63/src/jobservice/api/authenticator.go#L69-L69 To avoid this issue, constant time comparison should be used. Impact This attack might be possible theoretically, but no workable proof of concept is available, and access complexity is set at High. The jobservice exposes these APIs It is used to create jobs/stop job tasks and retrieve job task information. If an attacker obtains the secrets, it is possible to retrieve the job information, create a job, or stop a job task. The following versions of Harbor are involved: <=Harbor 2.8.2, <=Harbor 2.7.2, <= Harbor 2.6.x, <=Harbor 1.10.17 Patches Harbor 2.8.3, Harbor 2.7.3, Harbor 1.10.18 Workarounds Because the jobservice only exposes HTTP service to harbor-core containers, blocking any inbound…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mq6f-5xh5-hgcf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-20902

Advisory: Harbor timing attack risk
IDs: CVE-2023-20902, GHSA-mq6f-5xh5-hgcf
Record: https://patchnext.com/advisories/cve-2023-20902 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/goharbor/harbor 2.8.3, 2.7.3, 1.10.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/goharbor/harbor: affected < 1.10.18; >= 2.0.0, < 2.7.3; >= 2.8.0, < 2.8.3; fixed in 2.7.3, 1.10.18, 2.8.3

## Suggested inspection (read-only)
- Go github.com/goharbor/harbor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/goharbor/harbor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mq6f-5xh5-hgcf (GitHub-reviewed advisory GHSA-mq6f-5xh5-hgcf lists affected ranges: Go github.com/goharbor/harbor >=0 =2.0.0 =2.8.0 <2.8.3)

Commands are suggestions: review each one before running it.

Loading voting…