Answer vulnerable to account takeover because password reset links do not expire
CVE-2023-1976GHSA-j97g-77fj-9c4p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/answerdev/answer 1.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/answerdev/answer
- Affected
- < 1.0.6
- Fixed in
- 1.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j97g-77fj-9c4p lists affected ranges: Go github.com/answerdev/answer >=0 <1.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-1976: 0.61% estimated exploitation activity in the next 30 days; percentile 49.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
answerdev/answer is an open-source knowledge-based community software. Answer prior to 1.0.6 is vulnerable to account takeover because the password reset link does not expire.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j97g-77fj-9c4p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-1976 Advisory: Answer vulnerable to account takeover because password reset links do not expire IDs: CVE-2023-1976, GHSA-j97g-77fj-9c4p Record: https://patchnext.com/advisories/cve-2023-1976 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/answerdev/answer 1.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/answerdev/answer: affected < 1.0.6; fixed in 1.0.6 ## Suggested inspection (read-only) - Go github.com/answerdev/answer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/answerdev/answer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j97g-77fj-9c4p (GitHub-reviewed advisory GHSA-j97g-77fj-9c4p lists affected ranges: Go github.com/answerdev/answer >=0 <1.0.6) Commands are suggestions: review each one before running it.
Loading voting…