hibernate-validator Cross-site Scripting vulnerability
CVE-2023-1932GHSA-x83m-pf6f-pf9g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.hibernate.validator:hibernate-validator 6.2.0.Final; org.hibernate:hibernate-validator 6.2.0.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.hibernate.validator:hibernate-validator
- Affected
- < 6.2.0.Final
- Fixed in
- 6.2.0.Final
Maven org.hibernate:hibernate-validator
- Affected
- < 6.2.0.Final
- Fixed in
- 6.2.0.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x83m-pf6f-pf9g lists affected ranges: Maven org.hibernate.validator:hibernate-validator >=0 =0 <6.2.0.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-1932: 0.49% estimated exploitation activity in the next 30 days; percentile 42.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in hibernate-validator's 'isValid' method in the org.hibernate.validator.internal.constraintvalidators.hv.SafeHtmlValidator class, which can be bypassed by omitting the tag ending in a less-than character. Browsers may render an invalid html, allowing HTML injection or Cross-Site-Scripting (XSS) attacks.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x83m-pf6f-pf9g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-1932 Advisory: hibernate-validator Cross-site Scripting vulnerability IDs: CVE-2023-1932, GHSA-x83m-pf6f-pf9g Record: https://patchnext.com/advisories/cve-2023-1932 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.hibernate.validator:hibernate-validator 6.2.0.Final; org.hibernate:hibernate-validator 6.2.0.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.hibernate.validator:hibernate-validator: affected < 6.2.0.Final; fixed in 6.2.0.Final - Maven org.hibernate:hibernate-validator: affected < 6.2.0.Final; fixed in 6.2.0.Final ## Suggested inspection (read-only) - Maven org.hibernate.validator:hibernate-validator: check the installed version with your package manager. - Maven org.hibernate:hibernate-validator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.hibernate.validator:hibernate-validator, org.hibernate:hibernate-validator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x83m-pf6f-pf9g (GitHub-reviewed advisory GHSA-x83m-pf6f-pf9g lists affected ranges: Maven org.hibernate.validator:hibernate-validator >=0 =0 <6.2.0.Final) Commands are suggestions: review each one before running it.
Loading voting…