Mattermost fails to properly authentication inviter's permissions to private channel
CVE-2023-1774GHSA-9hj7-v56g-rhf6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server/v6 7.1.6; github.com/mattermost/mattermost-server 7.7.2, 7.1.6; github.com/mattermost/mattermost-server/v5 7.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-server/v6
- Affected
- >= 6.0.0, <= 6.7.2
- Fixed in
- 7.1.6
Go github.com/mattermost/mattermost-server
- Affected
- >= 3.3.0, <= 4.10.10>= 7.7.0, <= 7.7.1>= 7.1.0, <= 7.1.5
- Fixed in
- 7.7.2, 7.1.6
Go github.com/mattermost/mattermost-server/v5
- Affected
- >= 5.0.0, <= 5.39.3
- Fixed in
- 7.1.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9hj7-v56g-rhf6 lists affected ranges: Go github.com/mattermost/mattermost-server >=3.3.0 =7.7.0 =7.1.0 =5.0.0 =6.0.0 <=6.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2023-1774: 0.32% estimated exploitation activity in the next 30 days; percentile 24.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When processing an email invite to a private channel on a team, Mattermost fails to validate the inviter's permission to that channel, allowing an attacker to invite themselves to a private channel. Issue Identifier: MMSA-2023-00137
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9hj7-v56g-rhf6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-1774 Advisory: Mattermost fails to properly authentication inviter's permissions to private channel IDs: CVE-2023-1774, GHSA-9hj7-v56g-rhf6 Record: https://patchnext.com/advisories/cve-2023-1774 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server/v6 7.1.6; github.com/mattermost/mattermost-server 7.7.2, 7.1.6; github.com/mattermost/mattermost-server/v5 7.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost-server/v6: affected >= 6.0.0, <= 6.7.2; fixed in 7.1.6 - Go github.com/mattermost/mattermost-server: affected >= 3.3.0, <= 4.10.10; >= 7.7.0, <= 7.7.1; >= 7.1.0, <= 7.1.5; fixed in 7.7.2, 7.1.6 - Go github.com/mattermost/mattermost-server/v5: affected >= 5.0.0, <= 5.39.3; fixed in 7.1.6 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server/v5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9hj7-v56g-rhf6 (GitHub-reviewed advisory GHSA-9hj7-v56g-rhf6 lists affected ranges: Go github.com/mattermost/mattermost-server >=3.3.0 =7.7.0 =7.1.0 =5.0.0 =6.0.0 <=6.7.2) Commands are suggestions: review each one before running it.
Loading voting…