Keycloak Untrusted Certificate Validation vulnerability
CVE-2023-1664GHSA-5cc8-pgp5-7mpm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-core 21.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.keycloak:keycloak-core
- Affected
- < 21.1.2
- Fixed in
- 21.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5cc8-pgp5-7mpm lists affected ranges: Maven org.keycloak:keycloak-core >=0 <21.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2023-1664: 0.43% estimated exploitation activity in the next 30 days; percentile 36.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in keycloak-core. This flaw considers the scenario when using X509 Client Certificate Authenticatior with the option "Revalidate Client Certificate". A user may be able to choose, if directly connect to keycloak (not passing via reverse proxy) a specific certificate. If there's a configuration error in KCSPITRUSTSTOREFILEFILE the authenticator allows even with the "Cannot validate client certificate trust: Truststore not available" message as there's no certificate to trust against.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5cc8-pgp5-7mpm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-1664 Advisory: Keycloak Untrusted Certificate Validation vulnerability IDs: CVE-2023-1664, GHSA-5cc8-pgp5-7mpm Record: https://patchnext.com/advisories/cve-2023-1664 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-core 21.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.keycloak:keycloak-core: affected < 21.1.2; fixed in 21.1.2 ## Suggested inspection (read-only) - Maven org.keycloak:keycloak-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.keycloak:keycloak-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5cc8-pgp5-7mpm (GitHub-reviewed advisory GHSA-5cc8-pgp5-7mpm lists affected ranges: Maven org.keycloak:keycloak-core >=0 <21.1.2) Commands are suggestions: review each one before running it.
Loading voting…