Skip to content

← Actionable
High, CVSS 7.3

sccache vulnerable to privilege escalation if server is run as root

CVE-2023-1521GHSA-x7fr-pg8f-93f5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sccache 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io sccache

    Affected
    < 0.4.0
    Fixed in
    0.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2023-1521: 0.36% estimated exploitation activity in the next 30 days; percentile 30.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact On Linux the sccache client can execute arbitrary code with the privileges of a local sccache server, by preloading the code in a shared library passed to LDPRELOAD. If the server is run as root (which is the default when installing the snap package), this means a user running the sccache client can get root privileges. Patches Upgrade to 0.4.0 Workarounds Don't run sccache server as root. GitHub Security Lab number GHSL-2023-046

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x7fr-pg8f-93f5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-1521

Advisory: sccache vulnerable to privilege escalation if server is run as root
IDs: CVE-2023-1521, GHSA-x7fr-pg8f-93f5
Record: https://patchnext.com/advisories/cve-2023-1521 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sccache 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io sccache: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- crates.io sccache: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sccache.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x7fr-pg8f-93f5 (GitHub-reviewed advisory GHSA-x7fr-pg8f-93f5 lists affected ranges: crates.io sccache >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…