Skip to content

← Actionable
High, CVSS 7.5amended

gRPC Reachable Assertion issue

CVE-2023-1428GHSA-6628-q6j9-w8vg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.grpc:grpc-protobuf 1.53.0; grpc 1.53.0; grpcio 1.53.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.grpc:grpc-protobuf

    Affected
    >= 1.51.0, < 1.53.0
    Fixed in
    1.53.0
  • RubyGems grpc

    Affected
    >= 1.51.0, < 1.53.0
    Fixed in
    1.53.0
  • PyPI grpcio

    Affected
    >= 1.51.0, < 1.53.0
    Fixed in
    1.53.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-1428: 0.41% estimated exploitation activity in the next 30 days; percentile 34.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There exists an vulnerability causing an abort() to be called in gRPC. The following headers cause gRPC's C++ implementation to abort() when called via http2: te: x (x != trailers) :scheme: x (x != http, https) grpclbclientstats: x (x == anything) On top of sending one of those headers, a later header must be sent that gets the total header size past 8KB. We recommend upgrading past git commit 2485fa94bd8a723e5c977d55a3ce10b301b437f8 or v1.53 and above.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6628-q6j9-w8vg

  2. Revision 1 · created ·

    Published from osv record GHSA-6628-q6j9-w8vg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-1428

Advisory: gRPC Reachable Assertion issue
IDs: CVE-2023-1428, GHSA-6628-q6j9-w8vg
Record: https://patchnext.com/advisories/cve-2023-1428 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.grpc:grpc-protobuf 1.53.0; grpc 1.53.0; grpcio 1.53.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.grpc:grpc-protobuf: affected >= 1.51.0, < 1.53.0; fixed in 1.53.0
- RubyGems grpc: affected >= 1.51.0, < 1.53.0; fixed in 1.53.0
- PyPI grpcio: affected >= 1.51.0, < 1.53.0; fixed in 1.53.0

## Suggested inspection (read-only)
- Maven io.grpc:grpc-protobuf: check the installed version with your package manager.
- RubyGems grpc: check the installed version with your package manager.
- `python -m pip show grpcio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.grpc:grpc-protobuf, grpc, grpcio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6628-q6j9-w8vg (OSV record GHSA-6628-q6j9-w8vg lists affected ranges: Maven io.grpc:grpc-protobuf >=1.51.0 =1.51.0 =1.51.0 <1.53.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6628-q6j9-w8vg (GitHub-reviewed advisory GHSA-6628-q6j9-w8vg lists affected ranges: Maven io.grpc:grpc-protobuf >=1.51.0 =1.51.0 =1.51.0 <1.53.0)

Commands are suggestions: review each one before running it.

Loading voting…