Hashicorp Consul vulnerable to denial of service
CVE-2023-1297GHSA-c57c-7hrj-6q6v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/consul 1.15.3, 1.14.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/hashicorp/consul
- Affected
- < 1.14.5>= 1.15.0, < 1.15.3
- Fixed in
- 1.14.5, 1.15.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c57c-7hrj-6q6v lists affected ranges: Go github.com/hashicorp/consul >=0 =1.15.0 <1.15.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-1297: 0.77% estimated exploitation activity in the next 30 days; percentile 55.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Consul and Consul Enterprise's cluster peering implementation contained a flaw whereby a peer cluster with service of the same name as a local service could corrupt Consul state, resulting in denial of service. This vulnerability was resolved in Consul 1.14.5, and 1.15.3
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c57c-7hrj-6q6v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-1297 Advisory: Hashicorp Consul vulnerable to denial of service IDs: CVE-2023-1297, GHSA-c57c-7hrj-6q6v Record: https://patchnext.com/advisories/cve-2023-1297 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/consul 1.15.3, 1.14.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/consul: affected < 1.14.5; >= 1.15.0, < 1.15.3; fixed in 1.14.5, 1.15.3 ## Suggested inspection (read-only) - Go github.com/hashicorp/consul: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/consul. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c57c-7hrj-6q6v (GitHub-reviewed advisory GHSA-c57c-7hrj-6q6v lists affected ranges: Go github.com/hashicorp/consul >=0 =1.15.0 <1.15.3) Commands are suggestions: review each one before running it.
Loading voting…