Cross-Site Request Forgery (CSRF) in wallabag/wallabag
CVE-2023-0735GHSA-2qxp-xmx6-cq4f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wallabag/wallabag 2.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wallabag/wallabag
- Affected
- < 2.5.4
- Fixed in
- 2.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2qxp-xmx6-cq4f lists affected ranges: Packagist wallabag/wallabag >=0 <2.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-0735: 0.30% estimated exploitation activity in the next 30 days; percentile 22.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-Site Request Forgery (CSRF) in GitHub repository wallabag/wallabag prior to 2.5.4.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2qxp-xmx6-cq4f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-0735 Advisory: Cross-Site Request Forgery (CSRF) in wallabag/wallabag IDs: CVE-2023-0735, GHSA-2qxp-xmx6-cq4f Record: https://patchnext.com/advisories/cve-2023-0735 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wallabag/wallabag 2.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wallabag/wallabag: affected < 2.5.4; fixed in 2.5.4 ## Suggested inspection (read-only) - Packagist wallabag/wallabag: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wallabag/wallabag. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2qxp-xmx6-cq4f (GitHub-reviewed advisory GHSA-2qxp-xmx6-cq4f lists affected ranges: Packagist wallabag/wallabag >=0 <2.5.4) Commands are suggestions: review each one before running it.
Loading voting…