Skip to content

← Actionable
Medium, CVSS 5.4

wallabag subject to Improper Authorization via annotations

CVE-2023-0610GHSA-mrqx-mjc4-vfh3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wallabag/wallabag 2.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2023-0610: 0.44% estimated exploitation activity in the next 30 days; percentile 38.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The annotations feature lets users add annotations on highlighted parts of an entry. The controller does not validate authorization on PUT and DELETE requests which lets a logged user modify or delete any annotation using their ID on their endpoints example.org/annotations/{id}. These vulnerable requests also disclose highlighted parts of the entry to the attacker. You should immediately patch your instance to version 2.5.3 or higher if you have more than one user and/or having open registration. Resolution A user check is now done in the vulnerable methods before applying change on an annotation. The Annotation retrieval through a ParamConverter has also been replaced with a call to the AnnotationRepository in order to prevent any information disclosure through response discrepancy. Workarounds Credits We would like to thank @bAuh0lz for reporting this issue through huntr.dev. Reference: https://huntr.dev/bounties/8fdd9b31-d89b-4bbe-9557-20b960faf926/

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mrqx-mjc4-vfh3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0610

Advisory: wallabag subject to Improper Authorization via annotations
IDs: CVE-2023-0610, GHSA-mrqx-mjc4-vfh3
Record: https://patchnext.com/advisories/cve-2023-0610 (revision 1, source checked 26 Oct 2026, 14:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wallabag/wallabag 2.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist wallabag/wallabag: affected >= 2.0.0-beta.1, < 2.5.3; fixed in 2.5.3

## Suggested inspection (read-only)
- Packagist wallabag/wallabag: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wallabag/wallabag.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mrqx-mjc4-vfh3 (GitHub-reviewed advisory GHSA-mrqx-mjc4-vfh3 lists affected ranges: Packagist wallabag/wallabag >=2.0.0-beta.1 <2.5.3)

Commands are suggestions: review each one before running it.

Loading voting…