Skip to content

← Actionable
Medium, CVSS 6.5

wallabag contains Improper Authorization via export feature

CVE-2023-0609GHSA-qwx8-mxxx-mg96

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wallabag/wallabag 2.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-0609: 0.64% estimated exploitation activity in the next 30 days; percentile 50.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The export feature lets a user export a single entry or a set of entries in a given format (e.g. PDF, MOBI, TXT). For example, https://yourinstance.wallabag.org/export/45.pdf will export the entry with id 45 in PDF format. Since wallabag 2.0.0-alpha.1, this feature is vulnerable to an insecure direct object reference attack. A logged user can export any single entry without ownership validation. This is due to a lack of access validation in the downloadEntryAction method. You should immediately patch your instance to version 2.5.3 or higher if you have more than one user and/or having open registration. Resolution A user check is now done in the vulnerable method before sending the exported entry. The Entry retrieval through a ParamConverter has also been replaced with a call to the EntryRepository in order to prevent any information disclosure through response discrepancy. Workaround If you are unable to update to the latest version or if you want to temporarily limit…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qwx8-mxxx-mg96

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0609

Advisory: wallabag contains Improper Authorization via export feature
IDs: CVE-2023-0609, GHSA-qwx8-mxxx-mg96
Record: https://patchnext.com/advisories/cve-2023-0609 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wallabag/wallabag 2.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist wallabag/wallabag: affected >= 2.0.0-alpha.1, < 2.5.3; fixed in 2.5.3

## Suggested inspection (read-only)
- Packagist wallabag/wallabag: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wallabag/wallabag.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qwx8-mxxx-mg96 (GitHub-reviewed advisory GHSA-qwx8-mxxx-mg96 lists affected ranges: Packagist wallabag/wallabag >=2.0.0-alpha.1 <2.5.3)

Commands are suggestions: review each one before running it.

Loading voting…