Skip to content

← Actionable
Medium, CVSS 5.4amended

Cross-site Scripting in pyload-ng

CVE-2023-0488GHSA-wcm6-wv95-7jw6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev42), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyload-ng

    Affected
    < 0.5.0b3.dev42
    Fixed in
    0.5.0b3.dev42

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-0488: 0.83% estimated exploitation activity in the next 30 days; percentile 57.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site Scripting (XSS) - Stored in GitHub repository pyload/pyload prior to 0.5.0b3.dev42.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wcm6-wv95-7jw6

  2. Revision 1 · created ·

    Published from osv record GHSA-wcm6-wv95-7jw6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0488

Advisory: Cross-site Scripting in pyload-ng
IDs: CVE-2023-0488, GHSA-wcm6-wv95-7jw6
Record: https://patchnext.com/advisories/cve-2023-0488 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev42. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyload-ng: affected < 0.5.0b3.dev42; fixed in 0.5.0b3.dev42

## Suggested inspection (read-only)
- `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyload-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wcm6-wv95-7jw6 (OSV record GHSA-wcm6-wv95-7jw6 lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev42 (fixed))
- Verified: https://github.com/advisories/GHSA-wcm6-wv95-7jw6 (GitHub-reviewed advisory GHSA-wcm6-wv95-7jw6 lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev42)

Commands are suggestions: review each one before running it.

Loading voting…