Skip to content

← Actionable
Medium, CVSS 4.3amended

Cross-Site Request Forgery in modoboa

CVE-2023-0406GHSA-g298-59pg-93h7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (modoboa 2.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI modoboa

    Affected
    < 2.0.4
    Fixed in
    2.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-0406: 0.40% estimated exploitation activity in the next 30 days; percentile 34.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-Site Request Forgery (CSRF) in GitHub repository modoboa/modoboa prior to 2.0.4.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g298-59pg-93h7

  2. Revision 1 · created ·

    Published from osv record GHSA-g298-59pg-93h7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0406

Advisory: Cross-Site Request Forgery in modoboa
IDs: CVE-2023-0406, GHSA-g298-59pg-93h7
Record: https://patchnext.com/advisories/cve-2023-0406 (revision 2, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: modoboa 2.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI modoboa: affected < 2.0.4; fixed in 2.0.4

## Suggested inspection (read-only)
- `python -m pip show modoboa`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on modoboa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g298-59pg-93h7 (OSV record GHSA-g298-59pg-93h7 lists affected ranges: PyPI modoboa >=0 <2.0.4 (fixed))
- Verified: https://github.com/advisories/GHSA-g298-59pg-93h7 (GitHub-reviewed advisory GHSA-g298-59pg-93h7 lists affected ranges: PyPI modoboa >=0 <2.0.4)

Commands are suggestions: review each one before running it.

Loading voting…