pimcore is vulnerable to cross-site scripting via "title field " in data objects
CVE-2023-0323GHSA-6vf6-g3pr-j83h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 10.5.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/pimcore
- Affected
- < 10.5.14
- Fixed in
- 10.5.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6vf6-g3pr-j83h lists affected ranges: Packagist pimcore/pimcore >=0 <10.5.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-0323: 0.47% estimated exploitation activity in the next 30 days; percentile 40.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability is capable of resulting in stolen user cookies. Proof of Concept Patches Update to version 10.5.14 or apply this patch manually https://github.com/pimcore/pimcore/pull/13916.patch Workarounds Apply https://github.com/pimcore/pimcore/pull/13916.patch manually. References https://huntr.dev/bounties/129d6a4b-0504-4de1-a72c-3f12c4552343/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6vf6-g3pr-j83h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-0323 Advisory: pimcore is vulnerable to cross-site scripting via "title field " in data objects IDs: CVE-2023-0323, GHSA-6vf6-g3pr-j83h Record: https://patchnext.com/advisories/cve-2023-0323 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 10.5.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/pimcore: affected < 10.5.14; fixed in 10.5.14 ## Suggested inspection (read-only) - Packagist pimcore/pimcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/pimcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6vf6-g3pr-j83h (GitHub-reviewed advisory GHSA-6vf6-g3pr-j83h lists affected ranges: Packagist pimcore/pimcore >=0 <10.5.14) Commands are suggestions: review each one before running it.
Loading voting…