Skip to content

← Actionable
High, CVSS 7.4amended

Vulnerable OpenSSL included in cryptography wheels

CVE-2023-0286GHSA-x4qr-2fvf-3mr5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 39.0.1; openssl-src 300.0.12, 111.25.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI cryptography

    Affected
    >= 0.8.1, < 39.0.1
    Fixed in
    39.0.1
  • crates.io openssl-src

    Affected
    < 111.25.0>= 300.0.0, < 300.0.12
    Fixed in
    111.25.0, 300.0.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
  • CVE-2023-0286: 69.29% estimated exploitation activity in the next 30 days; percentile 99.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.8.1-39.0.0 are vulnerable to a security issue. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20221213.txt and https://www.openssl.org/news/secadv/20230207.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x4qr-2fvf-3mr5

  2. Revision 1 · created ·

    Published from osv record GHSA-x4qr-2fvf-3mr5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0286

Advisory: Vulnerable OpenSSL included in cryptography wheels
IDs: CVE-2023-0286, GHSA-x4qr-2fvf-3mr5
Record: https://patchnext.com/advisories/cve-2023-0286 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cryptography 39.0.1; openssl-src 300.0.12, 111.25.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cryptography: affected >= 0.8.1, < 39.0.1; fixed in 39.0.1
- crates.io openssl-src: affected < 111.25.0; >= 300.0.0, < 300.0.12; fixed in 111.25.0, 300.0.12

## Suggested inspection (read-only)
- `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active.
- crates.io openssl-src: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cryptography, openssl-src.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x4qr-2fvf-3mr5 (OSV record GHSA-x4qr-2fvf-3mr5 lists affected ranges: PyPI cryptography >=0.8.1 =0 =300.0.0 <300.0.12 (fixed))
- Verified: https://github.com/advisories/GHSA-x4qr-2fvf-3mr5 (GitHub-reviewed advisory GHSA-x4qr-2fvf-3mr5 lists affected ranges: PyPI cryptography >=0.8.1 =0 =300.0.0 <300.0.12)

Commands are suggestions: review each one before running it.

Loading voting…