Skip to content

← Actionable
Medium, CVSS 6.5amended

Pyload Insufficient Session Expiration vulnerability

CVE-2023-0227GHSA-rv9x-wmw4-44qj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev36), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyload-ng

    Affected
    <= 0.5.0b3.dev35
    Fixed in
    0.5.0b3.dev36

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-0227: 0.67% estimated exploitation activity in the next 30 days; percentile 52.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Pyload 0.5.0b3.dev35 has an Insufficient Session Expiration vulnerability. A patch is available and anticipated to be part of version 0.5.0b3.dev36.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rv9x-wmw4-44qj

  2. Revision 1 · created ·

    Published from osv record GHSA-rv9x-wmw4-44qj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0227

Advisory: Pyload Insufficient Session Expiration vulnerability
IDs: CVE-2023-0227, GHSA-rv9x-wmw4-44qj
Record: https://patchnext.com/advisories/cve-2023-0227 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev36. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyload-ng: affected <= 0.5.0b3.dev35; fixed in 0.5.0b3.dev36

## Suggested inspection (read-only)
- `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyload-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rv9x-wmw4-44qj (OSV record GHSA-rv9x-wmw4-44qj lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev36 (fixed))
- Verified: https://github.com/advisories/GHSA-rv9x-wmw4-44qj (GitHub-reviewed advisory GHSA-rv9x-wmw4-44qj lists affected ranges: PyPI pyload-ng >=0 <=0.5.0b3.dev35)

Commands are suggestions: review each one before running it.

Loading voting…